Recently I picked up a New Astro City. It was in pretty rough shape…



Anyways, per usual I broke out the hose and Simple Green (I wonder if I get enough traffic for them to become a sponsor? Probably not). The display was particularly gross. Not as bad as my blast city, but still pretty bad.

So we go from this:


To this:


Now onto the rest of the cab. I didn’t take any photos of the post cleanup, it just took a lot of simple green and water really. This definitely needs to be repainted at some point, but not today. Here was the corpse after the clean.


Not looking too hot next to the blast…


Next up was ripping out the jamma harness and rewiring it. That took probably 4 hours. Wiring is such a pain. On the plus side I did improve a bunch of wiring in the cab from being spliced to using AMP connectors and whatnot.





Shockingly everything worked, including audio.


I then worked on the control panel. Removed the 50 yen sticker that had been placed on it, only to have a 100 yen sticker be underneath that. These 100 yen stickers are so much nicer! In the process of washing the CP the center bolt hole broke off so I had to use some abs cement to weld it back into place, see the hi-tech electrical tape stabilizing it?





With that in place I had to get a new cp, thankfully Jasen (of makes some awesome repros so I picked one up from him and applied a new overlay to it 😀

Then it was just a matter of buttoning the baby up! Right now I’m running Darksoft’s CPS2 multiboard in it, I might throw something else in there sometime, we’ll see!